Minibox V3.2 How to config ap+client mode
How to config ap+client mode
1. for now,this mode only suit for lede but not QSDK
2. We need to modify the config manually
3. Here is the two router one is ap the other one is client
Step 1 : config the ap router
1. DHCP enable
2. Mode : Access Point (WDS)
3. For example :
(1)Vim /etc/config/network (pls modify the config mark by red )
config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11a'
option path 'pci0000:00/0000:00:00.0'
option htmode 'VHT80'
option disabled '0'
option country 'US'
option legacy_rates '1'
option channel '36' // modify
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option wds '1'
option encryption 'psk2'
option ssid 'AP1'
option key '12345678'
config wifi-device 'radio1'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'platform/qca953x_wmac'
option htmode 'HT20'
option disabled '0'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'MiniBoxV3.2_C719'
option encryption 'none'
4.modify the firewall
U can modify it by LUCI (change all the reject into accept)
Step 2: config the client router
1. Disable DHCP
2. Mode: client(WDS) +AP
Notice : Client(WDS) ‘s ESSID must the same as Access point (WDS)
3./etc/config/network :
(1)Add config :
config interface 'wwan
option proto 'dhcp'
4./etc/config/wireless:
config wifi-device 'radio0'
option type 'mac80211'
option channel '36'
option hwmode '11a'
option path 'pci0000:00/0000:00:00.0'
option htmode 'VHT80'
option disabled '0'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option noscan '1'
option country 'US'
option legacy_rates '1'
config wifi-iface //must the same as the ap router
option ssid 'AP1'
option encryption 'psk2'
option device 'radio0'
option network 'wwan'
option mode 'sta'
option wds '1'
option key '12345678'
config wifi-iface
option device 'radio0'
option network 'lan'
option disable '0'
option mode 'ap'
option encryption 'psk2'
option key '23456789'
option ssid 'AP2'
config wifi-device 'radio1'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'platform/qca953x_wmac'
option htmode 'HT20'
option disabled '0'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'MiniBoxV3.2_C6DD'
option encryption 'none'
5.modify the firewall:
U can modify it by LUCI (change all the reject into accept)
Last but no least :
1.the router must be the difference network segment,otherwise it doesn’t work
2.Throufh DHCP can get the ip from AP1,if you want to set the ip manully,you should know that
Comments
So empty here ... leave a comment!